Dual-band Mikrotik AP configuration with CAPsMAN

Published: Sun 18 September 2022
Updated: Sun 18 September 2022 by Ludo In Hardware

Lost with your dual-band Mikrotik AP configuration? There are several CAPsMAN HowTo articles on setting up CAPsMAN, but none that I discovered mention a tiny aspect that seems to trip people up every time: a CAP with two WiFi radios, one for 2.4 GHz and one for 5 GHz. I'll show you how to configure properly your AP below using the command line, because screenshots become sometimes quickly outdated.

CAPsMAN is the centralized administration solution for MikroTik WiFi access points. While it is not as flashy as some others, it has several unique features and a pretty solid interface that make it a suitable choice for a variety of applications. But most, if not all, of the guides and forum questions I found only illustrate one configuration with only one radio. If you follow them, neither of our 2.4 or 5 GHz radios will be configured and start working.

Dual band CAPsMAN configuration

This requires two settings, one for 2.4 GHz and one for 5 GHz, to function with a dual band CAP like the 'cAP ac'. You instruct CAPsMAN on the configuration to use based on the wireless hardware enabled mode, such as 802.11 a,b,g,n,ac, and so on.

Configure a datapath called 'mydatapath' where you'll set the VLAN id for client data, assuming your Local Area Network is on a bridge named bridge1. This tells CAPsMAN where to add the CAP wireless interfaces.

/caps-man datapath
add bridge=bridge1 name=mydatapath vlan-id=100 vlan-mode=use-tag

Create two channel plans, one for 2.4 and one for 5 GHz:

/caps-man channel
add band=2ghz-g/n name=channel2
add band=5ghz-n/ac name=channel5

Next you will create two provisioning setups that will apply the proper configuration to the proper WiFi radio.

/caps-man provisioning
add action=create-dynamic-enabled hw-supported-modes=a master-configuration="CAPConf5G"
add action=create-dynamic-enabled hw-supported-modes=gn master-configuration="CAPConf2G"

Configure the security of the wireless network, nothing specific here, change this as you like and don't forget to set the secret key.

/caps-man security
add authentication-types=wpa-psk,wpa2-psk comment="Security for MYSSID" encryption=aes-ccm name=MYSSID

Configure the CAPsMAN with two different channel configurations, one each for 2.4 and 5 GHz. If you don’t have dual-band CAPs that is fine it will still work. Replace 'spain' by you country, and MYSSID by your security configuration.

/caps-man configuration
add channel=channel5 country=spain datapath=mydatapath \
    datapath.local-forwarding=no hide-ssid=no installation=indoor mode=ap name=\
    "CAPConf5G" security=MYSSID security.disable-pmkid=no ssid=MYSSID
add channel=channel2 country=spain datapath=mydatapath \
    datapath.local-forwarding=no hide-ssid=no installation=indoor mode=ap name=\
    "CAPConf2G" security=MYSSID security.disable-pmkid=no ssid=MYSSID

Finally, make sure CAPsMAN Manager is enabled,

/caps-man manager
set enabled=yes

...and is listening on the right interfaces, for example:

/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=ether1
add interface=bridge1

That's all! You should now have a functional CAPsMAN configuration to which you may add and control more CAPs. Now your laptop or phone should see both SSID’s 😁

If you have more questions, feel free to comment below, and if you want to support this blog, please consider using the affiliate links below:

LD. --

Speak your mind: